Perl Net::SSLeay stubborn install – fixed

I’ve been messing around trying to get DBD::Google install on perl via Cpan – but it was just failing every time…

Tracking the error back revealed that it was Net::SSLeay that was at fault – I tried to install it numerous times, but it kept coming up with an error;
Running install for module 'Net::SSLeay'
Running make for F/FL/FLORA/Net-SSLeay-1.36.tar.gz
Has already been unwrapped into directory /root/.cpan/build/Net-SSLeay-1.36-xtsjC4
Could not make: Unknown error
Running make test
Can't test without successful make
Running make install
Make had returned bad status, install seems impossible

Anyway – after a lot of digging – it turns out that SSLeay has OS dependancies – these are;

libnet-ssleay-perl
libnet-https-any-perl
libssl-dev

Once these are install – you can go back to perl cpan and the modules installs like normal.. Phew!

This entry was posted in General. Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>